すでに2.0もリリースされている便利なJavascriptですが2.0を使わず1.5を使っています。
理由は特に無いです。そして、使うときいつも書き方を忘れるのでメモ

<script language="JavaScript" type="text/javascript">
<!--
var installedVer=deconcept.SWFObjectUtil.getPlayerVersion();
var requiredver=9;
var requiredver2=45;

if(installedVer['major']==requiredver&&installedVer['rev']>=requiredver2
|| installedVer['major']>requiredver){
	var so=new SWFObject('swf/main.swf','main','1010','640','9.0.45.0','#ffffff');
	so.addParam('wmode','opaque');
	so.addParam('base','swf/');
	so.addParam('menu','false');
	so.write('flashcontent');
}else{
	プラグインのバージョンが低いときの処理
}
// -->